zane

Surfrider under maintenance

9 posts in this topic

Hi all, well came back from Wet 'n' Wild the today with disappointment, I when to the park just to ride Surfrider only to find it's under "maintenance"? which is not good, considering they only officially launched it last Friday and the advertising for it is everywhere. there was no notice to say that it wasn't operating or anything, just walked up to the Que and the actual ride Technician standing under the loading platform told me that it wasn't going to be operating today, and as you can Imagine I was devastated. I know new rides have bugs/glitches in the ride operating system, but the soft opening was to get ride of these? Whats going on? :angry: Zane.

Edited by zane

Share this post


Link to post
Share on other sites

These things happen. It's like SE. The queue is an hr wait yet they still run 1 train. It's just part of life. Atleast you live there so you can visit it anytime. So that's a positive. I do feel for you though. I'm hoping that all the rides are open when i go. Because my cousin is coming up. It'll be his 1st time at the parks.

Share this post


Link to post
Share on other sites

"Atleast you live there so you can visit it anytime. So that's a positive" That's not the point, I still payed to ride this thing, rang up the park on sunday to ask if it was operating and they replied with yes. and if it breaks down during the day, well that's a different story. I would rather line up for 2 hours to ride superman with one train then for it to not work at all.

Share this post


Link to post
Share on other sites

Yes it seems to be the standard, that if you lodge a complaint regarding a ride not in operation, when you check that it will be in operation, except in the case of bad weather, they usually with allow you a return pass or a free lunch voucher.

Share this post


Link to post
Share on other sites

Surfrider is back open... Unfortunately it was a problem that no one could have foreseen and was discovered in morning checks the day you visited the park (why it wasn't posted out the front I don't know??) Parts had to be sent from overseas which unfortunately took a few days. I can tell you though they were installed the second they arrived and tech services were just as annoyed as you the ride wasn't running... You'd think Intamin would know what they were doing by now wouldn't you!

Share this post


Link to post
Share on other sites
Surfrider is back open... Unfortunately it was a problem that no one could have foreseen and was discovered in morning checks the day you visited the park (why it wasn't posted out the front I don't know??) Parts had to be sent from overseas which unfortunately took a few days. I can tell you though they were installed the second they arrived and tech services were just as annoyed as you the ride wasn't running... You'd think Intamin would know what they were doing by now wouldn't you!
you'd think i mean these are multi-million dollor rides and they stuff up theie lucky the fault was in the startup not the harnesses

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Parkz Crew

    Support Parkz... join the Crew for:

    • Ad-banner free viewing
    • Parkz Crew profile badge
    • Extended editing
    • See who's liked your posts
    • Purchase discounts

    Join Now from $20/yr

  • Recently Browsing

    No registered users viewing this page.