jdool16

Jet Rescue Stuck

6 posts in this topic

I was at Seaworld to day and I was walking to the Jet Rescue and I saw that people where walking out of the tunnel (second launch). I asked one of the staff what was happening and she said that the train stopped in side of the tunnel but there not sure why??? Has any boddy seen this before??? And For some reason there was a delayed opening and only 1 train was opperating.

Edited by jdool16

Share this post


Link to post
Share on other sites

1 train operating was probably because it was quiet since the holidays are nearly over. A few weeks ago they had problems with the sensors on the station launch which took over an hour to replace. I assume it's like other rides, if the sensor loses track of the ride, it shuts down, if the sensor wont reset itself, they walk people off and fix the ride

Share this post


Link to post
Share on other sites

I was there yesterday too. I saw it running through a test cycle after the reset. I'd say it wasn't a busy day, but being school holidays aren't technically over, the extra train would have made the day just that bit better. Dolphin Cove and the Pirates show were packed. Sea Viper was in the last switchback before the wall.

Share this post


Link to post
Share on other sites

The first day that I went to ride Jet Rescue, they were having issues with it getting stuck in the second launch tunnel. It would launch from the station OK, and then stop when it got into the tunnel. The tech/engineer guy walked the length of the station and through the door into the tunnel, did something there, and they were eventually able to get it to launch from there and complete the ride. They sent another test run, and the same thing happened again. It was about this time I decided to go try something else. I came back and saw they'd managed to get one complete test run through, but they still weren't ready to open the ride yet. I left the park shortly after that

Share this post


Link to post
Share on other sites
The first day that I went to ride Jet Rescue, they were having issues with it getting stuck in the second launch tunnel.
Funny that, I saw it broken the very first day I rode too. I'd say it was probably around last April? But I want on the Jet Rescue first thing in the day and then at about 10:30 it just stopped in the tunnel. From what I recall I think they had it back up and running within an hour...

Share this post


Link to post
Share on other sites

This doesn't surprise me, when you think about it, there are a lot of factors that have to be 'just right' for that 2nd launch to work. It's not as simple as just having the train hit a bunch of tyres spinning really fast... It's a pretty clever system really. And besides, it's Intamin, just wouldn't be right if it worked all the time!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Parkz Crew

    Support Parkz... join the Crew for:

    • Ad-banner free viewing
    • Parkz Crew profile badge
    • Extended editing
    • See who's liked your posts
    • Purchase discounts

    Join Now from $20/yr

  • Recently Browsing

    No registered users viewing this page.